Cinelerra dapper packages are in

So, today I built Cinelerra dapper packages. Quick instructions until I updated the README:

to your /etc/apt/sources.list (or whatever GUI interface to apt sources you are using) add:

deb http://archive.ubuntu.com/ubuntu dapper main universe multiverse restricted
(note the universe and multiverse)

and then add:

deb http://www.kiberpipa.org/~gandalf/ubuntu/dapper/mjpegtools ./

this time I’ve backported/rebuilt all the dependencies so there is no need for marilliat repository anymore.

Now you can add one of the following depending your arch:

deb http://www.kiberpipa.org/~gandalf/ubuntu/dapper/cinelerra/i686/ ./
or
deb http://www.kiberpipa.org/~gandalf/ubuntu/dapper/cinelerra/pentium4/ ./
or
deb http://www.kiberpipa.org/~gandalf/ubuntu/dapper/cinelerra/athlonxp/ ./

and then of course:

apt-get install cinelerra

So with formal instructions out of the way, I’d like to thank everyone who mailed me or otherwise bugged for these packages. Also please note that since a few months I’m not using Ubuntu anymore so I have to rely on your feedback to actually find out about bugs or breakage.

Andraz also figured out a few days ago how to build amd64 version of cinelerra packages so they might also happen quite soon.

30 thoughts on “Cinelerra dapper packages are in

  1. Thanks for the packages! I could install Cinerrela, but the mjpegtools package conflicts with the original dapper one (mjpegtools0c2a) :

    libmjpegtools0_1%3a1.8.0-0.1_i386.deb: intentando sobreescribir `/usr/lib/libmjpegutils-1.8.so.0.0.0′, que está también en el paquete libmjpegtools0c2a

    I could first uninstall mjpegtools0c2a, but this would prevent me to use transcode, wich depends on it.

  2. Franck: thanks for reporting this one. I fixed it already the other day but forgot to post it in the comments.

  3. Had so many problems with Cinelerra from other web sites and builds. Using Ubuntu, Dapper Drake and Kubuntu but running Ubuntu desktop. Tried yours for P4…

    I put all commands for P4 system into Konsole. Installed Cinelerra through Synaptic. After install got this…
    E: /var/cache/apt/archives/libiec61883-0_1.0.0-0.1_i386.deb: trying to overwrite `/usr/lib/libiec61883.so.0.0.0′, which is also in package libiec61883
    Cinelerra loaded but installation of all other apps and updates were failing until I ununstalled Cinelerra.

    Any ideas? I’m kind of a newbie to Linux. I do greatly appreciate your work on this though :)

  4. Have you got an AMD K8 package as well. Cinelerra was one of the reasons I decided to go for a 64 bit machine.

  5. Good job :-)

    But synaptic indicates me that it is broken.

    When i load the mpegtools, synaptic says that :

    E: /var/cache/apt/archives/libmjpegtools0c2a_1%3a1.8.0-0.0ubuntu1_i386.deb: tentative de remplacement de « /usr/lib/libmjpegutils-1.8.so.0.0.0 », qui appartient aussi au paquet libmjpegtools0

    apparently, libmjpegtools0c2a… can’t replace the libmjpegtolls0

    I’m using dapper

    thanks for response

  6. hello.

    i have following problem when apt-get install cinelerra

    Die folgenden Pakete haben nichterfüllte Abhängigkeiten:
    cinelerra: Hängt ab: libquicktimehv (>= 1:2.0.0) soll aber nicht installiert werden
    Hängt ab: libquicktimehv (= 1:2.0.0-1svn20060611.1) soll aber nicht installiert werden
    E: Kaputte Pakete

    i am using MEPIS linux based on the latest ubuntu dapper.

    what do i do wrong?

  7. Bonjour

    Je viens d’installer xubuntu et je voulais utiliser cinelerra. Aussi, je vous remercie beaucoup pour votre contribution. Le package marche très bien.

    Encore merci.

    Didiel

  8. THere’s a problem with libfaac-dev; in fact it require libmp4-dev, but that lib doesn’t exist…
    It should be named libmp4v2-dev !!!

    Please fix it ;)

    Many thanks for repository anyway!

  9. hi jure, great work, thanks a lot
    cin. installed without problems, libraries and dependencies seem to work fine!
    lots of greetings from constant brussels
    peter westenberg

  10. Hi, I tried your debian package for Ubuntu Dapper Drake but unfortunately I am getting the following error using Synaptics:

    cinelerra:
    Vereisten: libiec61883-0 but it is not installable
    Vereisten: libquicktimehv maar het wordt niet genstalleerd
    Vereisten: libraw1394-8 but it is not installable
    Vereisten: libquicktimehv maar het wordt niet genstalleerd

    vereisten means requirements (or something like that) in dutch. Any ideas what I can do about it?

  11. By the way, “maar het wordt niet geinstalleerd” means that it will not be installed. I noticed that for those libraries there are dependency errors. i.e.: newer or cvs versions are installed but clean or lower versions are required…

  12. Hi Friends,

    I encountered the following problem will installing Cinelerra. I am a newbie in Linux, Please help

    root@Anand:~# apt-get install cinelerra
    Reading package lists… Done
    Building dependency tree… Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.

    Since you only requested a single operation it is extremely likely that
    the package is simply not installable and a bug report against
    that package should be filed.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
    cinelerra: Depends: fftw3 but it is not installable
    Depends: libmjpegtools0c2a (>= 1:1.8.0-0.0ubuntu1) but it is not going to be installed
    E: Broken packages
    root@Anand:~#

    Look forward to your comments.

    Regards,

  13. Hello! I am having trouble! I cannot seem to install libmpeg3hv! here’s what happens:

    Unpacking libmpeg3hv (from …/libmpeg3hv_1%3a2.0.0-1svn20060611.1_i386.deb) …dpkg: error processing /var/cache/apt/archives/libmpeg3hv_1%3a2.0.0-1svn20060611.1_i386.deb (–unpack):
    trying to overwrite `/usr/bin/mpeg3cat’, which is also in package mpeg3-utils
    Errors were encountered while processing:
    /var/cache/apt/archives/libmpeg3hv_1%3a2.0.0-1svn20060611.1_i386.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)

    Any ideas?

  14. hello,

    i have install cinerella (Athon XP version), work well on Ubuntu 6.06 Dapper.

    Big Work !!! Many thanks !!!

    BUT, I loose “play sound file aac or mp4″ in xmms, bmp, gstreamer, etc …

    The problem is the “apt-get install cinelerra” replace the Ubuntu libfaad (and libfaac) packages.

    Ubuntu libfaad package procure :
    libfaac.so.0.0.0 libfaad.so.0.0.0 libmp4ff.so.0.0.0

    Cinelerra libfaad package procure :
    libfaac.so.0.0.0 libfaad.so.0.0.0

    When manually replace the libs ->
    - play aac sound files is ok in ubuntu
    - cinerella don’t work !

    the error is :
    “symbol lookup error : /usr/lib/libquicktimehv-1.6.0.so.1: undefined symbol: NeAACDecClose”

    I replace the libfaad cinerella version and …
    I listen aac and mp4 audio files with mplayer or vlc…

    Excuse me for my very poor english.
    hugos

  15. hi!

    I’ve got a similar problem: after mistakenly removing a lot of applications (including DVDrip, xmms-aac (or something like this, I think), …), and reinstalling most/all of them, cinelerra wouldn’t start:

    # cinelerra
    cinelerra: symbol lookup error: /usr/lib/libquicktimehv-1.6.0.so.1: undefined symbol: faacDecDecode

    I tried removing and reinstalling libquicktime and some other stuff, but no effect, same results with cinelerra.

    greetz, ro

  16. Sup.

    After much grief and searching for dependencies I finally got cinellera installed, only to find that it wouldn’t start due to the exact same problem with the libquicktimehv file that roman had.

    :(

    any ideas?

  17. THANKS!!

    I spend all day browsing arounds forums and trying different “how-to’s” but without luck.

    And i tried yours and IT WORKS PERFECTLY!

    Now i just have to figure out how to use it. :)

Comments are closed.